Ask a question

MOTEC UTC USB TO CAN ADAPTER

Part No 61059 Software Requirements for UTC Compatibility: -M400, M600, M800, M880 - V2.30S or later -PDM16, PDM32, PDM15, PDM30 - V1.0 or later -BR2 - V1.0.6.2 (this software ships with all data logging manager software) -DBW4 - V1.03 or later -SDC, SDC2, SDC3 - V1.21 or later -MDC - V1.22 or later -MDC2 - V2.0 or later -LTC - V1.0 or later -ADL - V3.20P or later
UTC USB to CAN adapter motec.jpg
Characters written: